Regarding Yeti1000X

Rognjen Member Posts: 2 ✭✭

I have a Yeti100X that is plugged in but is not charging. It is at 47%. I have tried unplugging and plugging back in. It is in an unheated garage that is about 40* F. It was purchased 8/22 from Costco. What should I do?


    GOAL ZERO ADMIN Member, Administrator, Moderator Posts: 433 admin

    Hi @Rognjen

    We are sorry to hear about the charging issues you are experiencing. It might be a good idea to take the Yeti inside so it can get up to room temperature. If the internal battery is below 32 degrees F it will have issues taking a charge.

    Please unplug everything from the Yeti and try doing a factory reset. Hold the Units and Info buttons at the same time for about 7-10 seconds. Once you hear the Yeti beep you can let go. Try plugging the power supply back into the Yeti. If it is still not taking a charge please email us with your proof of purchase and we will look into warranty options.

    [email protected]

  • Rognjen
    Rognjen Member Posts: 2 ✭✭

    Thank you. I left it unplugged for awhile, and the plugged it back in. It then fully charged.