Yeti Link No Longer Charging my 1000X

SchoMan93 Member Posts: 6 ✭✭

I have had my Yeti 1000X, with link for over a year now, and the link is no longer charging my yeti. It will charge and hold the expansion batteries I have hooked up, but not the Yeti. I have pulled the link and disconnected it, then re-connected tit with the same results. The system worked great for 18 months without issue. I have tried to re-set both the Link and the Yeti, still no change. any suggestions on other things to try to get it to work again?


    GOAL ZERO ADMIN Member, Administrator, Moderator Posts: 506 admin

    Hi @SchoMan93,

    Is the Yeti link in Tank mode or Car mode? If you are unsure, you can check by pressing the reset button (it is the pin sized hole in the middle right on top of the Yeti link) once. This will make the 4 green LED light flash. If they all flash in sequence 3 times, that means its in Car mode. If they flash from bottom to top, that means it is in Tank mode. You want to make sure that the Link is in tank mode as it will not output any power to the Yeti in car mode.

    If you need to switch the mode, you press the reset button 4 times.

  • SchoMan93
    SchoMan93 Member Posts: 6 ✭✭

    The unit is in Tank Mode. Yes I have done the reset button once with no effect. I did it 4 times to move it into Vehicle Mode, then 4 times again to put it into Tank Mode. It is still not charging the Yeti. Yes the lights flashed as you described, and what is described in the Link User Guide.

  • HarryO
    HarryO Member Posts: 1 ✭✭

    I'm having this exact same problem. Yeti 1000x, expansion unit and the link module. The Yeti 1000x has no stored power. The tanks seem fine, but when I plug something in to the yeti 1000x nothing happens. Why is it not even using the electricity in the tanks? I disconnected the tanks and took the link module out just to see if the yeti 1000x would charge, but its not. Just blue blinking lights. I did call this in. Case number 38-21563

  • SchoMan93
    SchoMan93 Member Posts: 6 ✭✭

    I called in in early April and worked it out with Customer Service. It was the expansion module that failed on my end. Once we had run through the troubleshooting, they emailed me a RMA return label. I got the new expansion module in about 10 days after my initial call into customer service. Installed the new module and everything worked. Customer service did a great job walking me through troubleshooting and resolution.

    I have had multiple different units dating back to 2009, when I got my first set-up with 4 Boulder 30 solar panels. Add in the other 7 solar panels, two other power stations, and 4 expansion batteries and multiple cables the this has been the only item to have failed under the warranty period. My first two 150W batteries that I got back in 2009 finally stopped storing charge in 2018, only because the batteries were all worn out. I have been very happy with all of my products, and they have been totally helpful over the years for camping with medical devices, several multi day power outages, and tailgating to run my pellet grill and charge phones on family outings.

  • ChasCPB
    ChasCPB Member Posts: 2 ✭✭
    edited September 9

    I tried the same thing. My Tanks seem to be fully charged. I reset the Link to Tank Mode to be sure and it is still not charging my Yeti3000. So, I will call customer support and troubleshoot with them. I assume I need a new Yeti Link.