1500X MPPT board replacement

rconiv Member Posts: 2 ✭✭

Does anyone know where I can get a MPPT board for a 1500X? I got my system used at an REI garage sale, and since you can't really test solar in a store, I didn't know that didn't work till I got it home. Since it was used, it isn't covered by warranty. One of the AC jacks was bad also.

I have already tried doing multiple resets and firmware updates and the solar and one A/C port doesn't work. I opened it up and found if I moved the connectors for the two AC ports, the issue followed, but I still couldn't charge through solar.

Got all the way to the point of disconnecting and dropping the battery out so I could pull the MPPT board, to see if any components were obviously failed or there was bad solder joints but I didn't see anything.

I have tried to charge it with multiple different boulder 100 and nomad 200s, with different charging cables to rule out the solar arrays or charging cables. They work fine on my 400's and 150X.

Outside of that, it has worked great. Do need to see about getting the 440 charger for it.


  • jg164
    jg164 Administrator, Moderator Posts: 156 admin


    If you have not been able to get a charge through the HPP or 8mm ports (No watts in an the blue LED does not blink at all), there is still the USBC input and the module port (under the lid under a screwed on cover) which bypass that board. Unfortunately we do not offer MPPT PCBs for sale. You can try to add an MPPT module to get this unit to work.

  • rconiv
    rconiv Member Posts: 2 ✭✭
    edited May 26

    I actually got the MPPT module, and nothing charges through it either. I had one Goal Zero person tell me it should work, and after I got it, another said it wasn't for that system, and wouldn't work, so yea.

    When I plug AC into the one that doesn't work, it is just solid blue instead of blinking blue, and the display doesn't show any charging happening. The same thing happens with the MPPT module, and I also couldn't get the screws it came with to screw in to hold it in place, and getting the USB micro-d cable to not get crimped in there because it was a small pocket was tough.

    In the description for the module, it says this "Not compatible with X line power supplies, only compatible with Yeti LI power supplies." What does that mean? Does it not work with the power cord that came with the 1500X or does it mean something else?